Yogesh Ashok Powar <yogeshp@xxxxxxxxxxx> writes: > For AP mode, driver sets IEEE80211_HW_CRYPTO_ENABLED hardware flag to avoid > mac80211 reserving tail room space for crypto suite. A small style issue: > + /* This is needed to avoid tailroom calculations */ > + hw->flags |= priv->ap_fw ? IEEE80211_HW_CRYPTO_ENABLED : 0; Why not just: if (priv->ap_fw) hw->flags |= IEEE80211_HW_CRYPTO_ENABLED A lot easier to read. -- Kalle Valo -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html