On Fri, Apr 08, 2011 at 09:45:00PM +0200, RafaÅ MiÅecki wrote: > Cc: Michael BÃsch <mb@xxxxxxxxx> > Cc: Larry Finger <Larry.Finger@xxxxxxxxxxxx> > Cc: George Kashperko <george@xxxxxxxxxxx> > Cc: Arend van Spriel <arend@xxxxxxxxxxxx> > Cc: linux-arm-kernel@xxxxxxxxxxxxxxxxxxx <linux-arm-kernel@xxxxxxxxxxxxxxxxxxx> > Cc: Russell King <rmk@xxxxxxxxxxxxxxxx> > Cc: Arnd Bergmann <arnd@xxxxxxxx> > Cc: linuxdriverproject <devel@xxxxxxxxxxxxxxxxxxxxxx> > Cc: linux-kernel@xxxxxxxxxxxxxxx <linux-kernel@xxxxxxxxxxxxxxx> > Signed-off-by: RafaÅ MiÅecki <zajec5@xxxxxxxxx> > --- > This is second try for introducing new bus driver. > V2: Rename to axi > Use DEFINE_PCI_DEVICE_TABLE in bridge > Make use of pr_fmt and pr_* > Store core class > Rename bridge to not b43 specific > Replace magic 0x1000 with BCMAI_CORE_SIZE > Remove some old "ssb" names and defines > Move BCMAI_ADDR_BASE def > Add drvdata field > TODO: > - Interrupts > - Reloading driver Please add to the TODO list: - Documentation/ABI entries for new sysfs files - proper Kconfig entry documentation for the different options - remove unneeded pcicore_write* wrapper functions that do nothing. > +static void axi_release_core_dev(struct device *dev) > +{ > + kfree(dev); > +} This is wrong, unless you are really only creating a 'struct device'. Why are you doing that instead of embedding struct device in your structure? thanks, greg k-h -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html