On Wed, 2011-03-23 at 12:20 -0700, greearb@xxxxxxxxxxxxxxx wrote: > + sf += snprintf(buf, mxln - sf, "0x%x", local->hw.flags); > + if (local->hw.flags & IEEE80211_HW_HAS_RATE_CONTROL) > + sf += snprintf(buf + sf, mxln - sf, " HAS_RATE_CONTROL"); Wouldn't it be easier to read with "<flag>\n" rather than " <flag>"? > +static const struct file_operations hwflags_ops = { > + .read = hwflags_read, > + .open = mac80211_open_file_generic, > + .llseek = default_llseek, > +}; I think it'd make sense to split up the DEBUGFS_READONLY_FILE macro and use it? johannes -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html