On Monday 14 February 2011 10:11 AM, Mohammed Shafi wrote:
On Friday 11 February 2011 09:59 PM, John W. Linville wrote:
On Fri, Feb 11, 2011 at 05:21:06PM +0100, Felix Fietkau wrote:
On 2011-02-11 5:15 PM, John W. Linville wrote:
On Fri, Feb 11, 2011 at 01:52:23PM +0100, Felix Fietkau wrote:
On 2011-02-11 8:01 AM, Mohammed Shafi Shajakhan wrote:
From: Mohammed Shafi Shajakhan<mshajakhan@xxxxxxxxxxx>
Instead of using raw numbers to assign slot time it would be
better to
make use of predefined slot time macros
How does this make it better?
Maybe if it was ATH9K_SHORT_SLOT_TIME it would make more sense?
Well, neither the unit of this variable, nor the values that can be
used
are ath9k specific.
Felix then I don't know why these macros are used here and I followed
the same thing:
htc_drv_beacon.c 242 if (ah->slottime == ATH9K_SLOT_TIME_20)
init.c 517 sc->beacon.slottime = ATH9K_SLOT_TIME_9;
True -- the patch is probably an unnecessarily zealous attempt to avoid
"magic numbers" in the code. :-)
John there are two instances where these macros are used:
htc_drv_beacon.c 242 if (ah->slottime == ATH9K_SLOT_TIME_20)
init.c 517 sc->beacon.slottime = ATH9K_SLOT_TIME_9;
John
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html