There's a __packed #define for this __attribute__((packed)). Might as well get checkpatch to tell people about it. Signed-off-by: Joe Perches <joe@xxxxxxxxxxx> --- On Thu, 2010-12-16 at 10:21 -0500, John W. Linville wrote: > On Thu, Dec 16, 2010 at 09:05:12AM -0600, Larry Finger wrote: > > On 12/16/2010 08:34 AM, John W. Linville wrote: > > > Use "__packed" instead of "__attribute__ ((packed))"... > > As a point of interest, is this the "new" recommended way? The reason I ask is > > that the Linux headers are mostly in the attribute form. > AIUI, "__packed" is the one true way. I think this facilitates > compiling the kernel with compilers other than GCC. > > At any rate, Dave Miller threatened to injure me if I kept sending him stuff using > "__attribute__ ((packed))"... :-) scripts/checkpatch.pl | 5 +++++ 1 files changed, 5 insertions(+), 0 deletions(-) diff --git a/scripts/checkpatch.pl b/scripts/checkpatch.pl index e3c7fc0..6fc24af 100755 --- a/scripts/checkpatch.pl +++ b/scripts/checkpatch.pl @@ -2743,6 +2743,11 @@ sub process { WARN("plain inline is preferred over $1\n" . $herecurr); } +# Check for __attribute__ packed, prefer __packed + if ($line =~ /\b__attribute__\s*\(\s*\(.*\bpacked\b/) { + WARN("__packed is preferred over __attribute__((packed))\n" . $herecurr); + } + # check for sizeof(&) if ($line =~ /\bsizeof\s*\(\s*\&/) { WARN("sizeof(& should be avoided\n" . $herecurr); -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html