On Thu, 2010-09-23 at 06:56 -0700, Ben Greear wrote: > On 09/23/2010 01:33 AM, Johannes Berg wrote: > > On Wed, 2010-09-22 at 21:58 -0700, Ben Greear wrote: > > > > > >> + * @addr2: local address (vif->sdata->dev->dev_addr). Can be NULL for 'any'. > >> * > >> * This function must be called under RCU lock and the > >> * resulting pointer is only valid under RCU lock as well. > >> @@ -2434,7 +2435,8 @@ struct ieee80211_sta *ieee80211_find_sta(struct ieee80211_vif *vif, > >> * DO NOT USE THIS FUNCTION. > >> */ > >> struct ieee80211_sta *ieee80211_find_sta_by_hw(struct ieee80211_hw *hw, > >> - const u8 *addr); > >> + const u8 *addr, > >> + const u8 *localaddr); > > > > That's not going to generate proper documentation. Also, it now probably > > shouldn't be called "by_hw" any more. > > I can't think of a better name, and it still does take the hw struct, > but if you have a suggestion you like better, I will use it. Yeah, but it doesn't use the hw struct for matching (well, not necessarily anyway) ... so something like _by_ifaddr() would be better? johannes -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html