I'm developing on OpenWrt to work with EEPROM-less ath5k mini-pci
devices. This is needed to support the ar71xx-based Senao EAP7660D board
which got two AR5413 modules soldered into its mini-pci slots. In the
original Firmware, MAC addresses as well as calibration-data seems to be
part of the firmware blob stored on the board flash.
See
https://lists.openwrt.org/pipermail/openwrt-devel/2010-June/007366.html
for the corresponding discussion on OpenWrt-devel.
Similarly to the way this happens for ath9k, I managed to get ath5k to
use the MAC address and eeprom-data supplied by ath9k_platform_data.
Including ath9k_platform.h in ath5k-sources looks confusing as the name
ath9k_platform suggests that the supplied ath9k_platform_info struct is
specific to ath9k devices.
Consequently, I believe ath9k_platform.h should be renamed into
ath_platform.h, the macro ATH9K_PLAT_EEP_MAX_WORDS into
ATH_PLAT_EEP_MAX_WORDS and struct ath9k_platform_data should be
refactored to be struct ath_platform_data.
Please let me know if you agree with this in theory; if yes, I'll start
posting the patches to OpenWrt.
Cheers
Daniel
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html