Search Linux Wireless

Re: [PATCH v2] mac80211: Use a separate CCMP PN receive counter for management frames

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Fri, 2010-06-11 at 10:27 -0700, Jouni Malinen wrote:

> -		for (i = 0; i < NUM_RX_DATA_QUEUES; i++) {
> +		for (i = 0; i < NUM_RX_DATA_QUEUES + 1; i++) {

Perhaps we could have a define for NUM_RX_DATA_QUEUES + 1, e.g.
NUM_RX_ALL_QUEUES

> +			int queue = ieee80211_is_mgmt(fc) ?
> +				NUM_RX_DATA_QUEUES : rx->queue;

Again, it would be nice to add a define for readability, e.g.
#define NUM_RX_MGMT_QUEUE NUM_RX_DATA_QUEUES

-- 
Regards,
Pavel Roskin
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Host AP]     [ATH6KL]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Linux Kernel]     [IDE]     [Security]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite News]     [MIPS Linux]     [ARM Linux]     [Linux Security]     [Linux RAID]     [Linux ATA RAID]     [Samba]     [Device Mapper]
  Powered by Linux