> > +#define IEEE802154_ATTR_MAX (__IEEE802154_ATTR_MAX - 1) > > +#define NLA_HW_ADDR NLA_U64 > > +#define NLA_GET_HW_ADDR(attr, addr) do { u64 _temp = nla_get_u64(attr); memcpy(addr, &_temp, 8); } while (0) > > +#define NLA_PUT_HW_ADDR(msg, attr, addr) do { u64 _temp; memcpy(&_temp, addr, 8); NLA_PUT_U64(msg, attr, _temp); } while (0) What would you propose here? adding prefix will add length to macro, IEEE802154_NL_PUT_HW_ADDR is damn long name. Using repeated code sequence is not better (it is error-prone and unreadable). Any ideas? -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html