Marcel Holtmann wrote: >> range->enc_capa |= IW_ENC_CAPA_CIPHER_TKIP; >> else if (suite == WLAN_CIPHER_SUITE_CCMP) >> range->enc_capa |= IW_ENC_CAPA_CIPHER_CCMP; >> + else if (suite == WLAN_CIPHER_SUITE_WEP40) >> + range->encoding_size[range->num_encoding_sizes++] = >> + WLAN_KEY_LEN_WEP40; >> + else if (suite == WLAN_CIPHER_SUITE_WEP104) >> + range->encoding_size[range->num_encoding_sizes++] = >> + WLAN_KEY_LEN_WEP104; > > especially since you are now extending this list, please use a switch > statement. The code becomes hard to read. Sure, I'll change this to a switch. Thanks! Dave. -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html