Using break/continue inside a for() which is itself inside a do {} while, is asking for trouble... Instead of replacing the bogus "break" with "continue", use something far more readable, instead. Signed-off-by: Henrique de Moraes Holschuh <hmh@xxxxxxxxxx> --- net/rfkill/input.c | 12 ++++++------ 1 files changed, 6 insertions(+), 6 deletions(-) diff --git a/net/rfkill/input.c b/net/rfkill/input.c index f708d74..a7295ad 100644 --- a/net/rfkill/input.c +++ b/net/rfkill/input.c @@ -123,14 +123,14 @@ static void rfkill_op_handler(struct work_struct *work) continue; for (i = 0; i < NUM_RFKILL_TYPES; i++) { - if (!__test_and_clear_bit(i, rfkill_sw_pending)) - break; - c = __test_and_clear_bit(i, rfkill_sw_state); - spin_unlock_irq(&rfkill_op_lock); + if (__test_and_clear_bit(i, rfkill_sw_pending)) { + c = __test_and_clear_bit(i, rfkill_sw_state); + spin_unlock_irq(&rfkill_op_lock); - __rfkill_handle_normal_op(i, c); + __rfkill_handle_normal_op(i, c); - spin_lock_irq(&rfkill_op_lock); + spin_lock_irq(&rfkill_op_lock); + } } } while (rfkill_op_pending); spin_unlock_irq(&rfkill_op_lock); -- 1.6.3.1 -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html