Johannes Berg <johannes@xxxxxxxxxxxxxxxx> writes: >> --- a/net/mac80211/ieee80211_i.h >> +++ b/net/mac80211/ieee80211_i.h >> @@ -1078,6 +1078,7 @@ void ieee80211_dynamic_ps_timer(unsigned long data); >> void ieee80211_send_nullfunc(struct ieee80211_local *local, >> struct ieee80211_sub_if_data *sdata, >> int powersave); >> +void ieee80211_rx_trigger(struct ieee80211_sub_if_data *sdata); > > I think that could have a better name maybe? _sta_rx_notify? That's a lot better name, I'll rename it. >> +void ieee80211_rx_trigger(struct ieee80211_sub_if_data *sdata) >> +{ >> + if (sdata->vif.type == NL80211_IFTYPE_STATION) { >> + mod_timer(&sdata->u.mgd.timer, >> + jiffies + IEEE80211_MONITORING_INTERVAL); >> + } > > Should we have the sta check outside the function? Seems a little odd to > have a check in a file that only contains STATION mode code. Actually I first had the check in rx.c, then moved it to mlme.c just to have less changes in rx.c. But you have a point, I'll move the check back to rx.c. > Other than that, looks good to me. I'd have thought this would be more > complicated :) Luckily it wasn't, I prefer having simple patches :) -- Kalle Valo -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html