On 1/23/2025 12:30 AM, Aditya Kumar Singh wrote:
On 1/22/25 14:17, Miaoqing Pan wrote:
--- a/drivers/net/wireless/ath/ath12k/pci.c
+++ b/drivers/net/wireless/ath/ath12k/pci.c
@@ -1725,6 +1725,7 @@ static void ath12k_pci_remove(struct pci_dev *pdev)
if (test_bit(ATH12K_FLAG_QMI_FAIL, &ab->dev_flags)) {
ath12k_pci_power_down(ab, false);
ath12k_qmi_deinit_service(ab);
+ ath12k_fw_unmap(ab);
ath12k_core_hw_group_unassign(ab);
goto qmi_fail;
}
Instead of this, why not move the "qmi_fail:" label above unmap() ?
Good catch, the code base is changed a lot since the v1.