On 11/16/2024 1:40 AM, Christophe Leroy wrote: > > > Le 15/11/2024 à 22:26, Easwar Hariharan a écrit : >> [Vous ne recevez pas souvent de courriers de >> eahariha@xxxxxxxxxxxxxxxxxxx. Découvrez pourquoi ceci est important à >> https://aka.ms/LearnAboutSenderIdentification ] >> >> None of the higher order definitions are used anymore, so remove >> definitions for minutes, hours, and days timeouts. Convert the seconds >> denominated timeouts to secs_to_jiffies() > > There is very similar things with tcp_timeouts[] in > nf_conntrack_proto_tcp.c, why not convert it as well ? This patch happens to have been hand-modified and not by Coccinelle. I'll consider tcp_timeouts[] for v3, but that actually seems to have minute, hour, and days denominated timeouts, and replacing the 4 SECS timeouts may actually hinder readability in that file. > >> >> Signed-off-by: Easwar Hariharan <eahariha@xxxxxxxxxxxxxxxxxxx> >> --- >> net/netfilter/nf_conntrack_proto_sctp.c | 21 ++++++++------------- >> 1 file changed, 8 insertions(+), 13 deletions(-) >> >> diff --git a/net/netfilter/nf_conntrack_proto_sctp.c b/net/netfilter/ >> nf_conntrack_proto_sctp.c >> index >> 4cc97f971264ed779434ab4597dd0162586b3736..6c95ac96fa42a39acafb5b88a7cf8898010e911c 100644 >> --- a/net/netfilter/nf_conntrack_proto_sctp.c >> +++ b/net/netfilter/nf_conntrack_proto_sctp.c >> @@ -39,20 +39,15 @@ static const char *const sctp_conntrack_names[] = { >> [SCTP_CONNTRACK_HEARTBEAT_SENT] = "HEARTBEAT_SENT", >> }; >> >> -#define SECS * HZ >> -#define MINS * 60 SECS >> -#define HOURS * 60 MINS >> -#define DAYS * 24 HOURS >> - >> static const unsigned int sctp_timeouts[SCTP_CONNTRACK_MAX] = { >> - [SCTP_CONNTRACK_CLOSED] = 10 SECS, >> - [SCTP_CONNTRACK_COOKIE_WAIT] = 3 SECS, >> - [SCTP_CONNTRACK_COOKIE_ECHOED] = 3 SECS, >> - [SCTP_CONNTRACK_ESTABLISHED] = 210 SECS, >> - [SCTP_CONNTRACK_SHUTDOWN_SENT] = 3 SECS, >> - [SCTP_CONNTRACK_SHUTDOWN_RECD] = 3 SECS, >> - [SCTP_CONNTRACK_SHUTDOWN_ACK_SENT] = 3 SECS, >> - [SCTP_CONNTRACK_HEARTBEAT_SENT] = 30 SECS, >> + [SCTP_CONNTRACK_CLOSED] = secs_to_jiffies(10), >> + [SCTP_CONNTRACK_COOKIE_WAIT] = secs_to_jiffies(3), >> + [SCTP_CONNTRACK_COOKIE_ECHOED] = secs_to_jiffies(3), >> + [SCTP_CONNTRACK_ESTABLISHED] = secs_to_jiffies(210), >> + [SCTP_CONNTRACK_SHUTDOWN_SENT] = secs_to_jiffies(3), >> + [SCTP_CONNTRACK_SHUTDOWN_RECD] = secs_to_jiffies(3), >> + [SCTP_CONNTRACK_SHUTDOWN_ACK_SENT] = secs_to_jiffies(3), >> + [SCTP_CONNTRACK_HEARTBEAT_SENT] = secs_to_jiffies(3), > > Was 30 before, if you think it must be changed to 3 you must explain it > in the commit message, or maybe do another patch for that change. This one's a typo, I'll fix it in v3. Thanks, Easwar