Karthikeyan Periyasamy <quic_periyasa@xxxxxxxxxxx> wrote: > Currently, the Rxdma buffer replenish procedure implicitly retrieves the > number of free entries when the caller passes req_entries as zero. This is > helpful to replenishing the Rxdma ring when the caller is unaware of the > number of entries to replenish. After the Rxdma ring is initialized, we > can pass req_entries as zero to replenish all the free entry in the Rxdma > ring. This change helps to align the argument req_entries to the used list > entries for better code readability. > > Tested-on: QCN9274 hw2.0 PCI WLAN.WBE.1.0.1-00029-QCAHKSWPL_SILICONZ-1 > > Signed-off-by: Karthikeyan Periyasamy <quic_periyasa@xxxxxxxxxxx> > Signed-off-by: Kalle Valo <quic_kvalo@xxxxxxxxxxx> 3 patches applied to ath-next branch of ath.git, thanks. 9d7bce18e725 wifi: ath12k: Refactor Rxdma buffer replinish argument 597b4dd63afa wifi: ath12k: Optimize the lock contention of used list in Rx data path f42bfbe7a507 wifi: ath12k: Refactor error handler of Rxdma replenish -- https://patchwork.kernel.org/project/linux-wireless/patch/20240320010615.91331-2-quic_periyasa@xxxxxxxxxxx/ https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches