Baochen Qiang <quic_bqiang@xxxxxxxxxxx> writes: > This introduced some new concept: > power type of AP(STANDARD_POWER_AP, INDOOR_AP, VERY_LOW_POWER_AP) > power type of STATION(DEFAULT_CLIENT, SUBORDINATE_CLIENT) > power spectral density(psd) > > This patchset is to implement the new rules for 6 GHz band in > ath11k. > > ath11k parsed the reg rules from new WMI event > WMI_REG_CHAN_LIST_CC_EXT_EVENTID and parse the > transmit power envelope element in beacon of AP > and then set new WMI command WMI_VDEV_SET_TPC_POWER_CMDID > to firmware when connect to 6G AP, also support backward > compatibility with firmware which not support new wmi > cmd WMI_VDEV_SET_TPC_POWER_CMDID. > > v10: > 1. [PATCH 02/12] wifi: ath11k: store cur_regulatory_info for each radio > a. s/muti/multi/ > 2. [PATCH v9 09/12] wifi: ath11k: fill parameters for vdev set tpc power WMI command > a. add idle_ps check when calculating EIRP. I don't see Jeff's ack in patches 1, 11 and 12. Jeff, are you ok with these? I did some changes in the pending branch, below is a some kind of list of the changes. The changed patches are available in the pending branch (tag ath-pending-202401111604): https://git.kernel.org/pub/scm/linux/kernel/git/kvalo/ath.git/log/?h=pending multiple patches o whitespace changes, especially adding empty line before after if and for statements (also in other pathches) patch 1 o remove unneeded parenthesis patch 2 o ath11k_reg_reset_info(): invert if check o ath11k_reg_reset_info(), ath11k_reg_handle_chan_list(), ath11k_reg_get_ar_vdev_type(), ath11k_reg_is_world_alpha: move to reg.c, I did also consider renaming these to use ath11k_wmi_ prefix but thought that reg.c is more approriate place for them patch 11 o remove comments from enum wmi_tlv_cmd_id o other cosmetic changes in wmi.h -- https://patchwork.kernel.org/project/linux-wireless/list/ https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches