On Fri, 2023-02-17 at 10:31 +0100, Greg KH wrote: > On Fri, Feb 17, 2023 at 10:13:08AM +0100, Johannes Berg wrote: > > On Fri, 2023-02-17 at 08:43 +0100, Greg KH wrote: > > > On Fri, Feb 17, 2023 at 02:11:38PM +0900, Jaewan Kim wrote: > > > > BTW, can I expect you to review my changes for further patchsets? > > > > I sometimes get conflicting opinions (e.g. line limits) > > > > > > Sorry, I was the one that said "you can use 100 columns", if that's not > > > ok in the networking subsystem yet, that was my fault as it's been that > > > way in other parts of the kernel tree for a while. > > > > > > > Hah. Maybe that's my mistake then, I was still at "use 80 columns where > > it's simple, and more if it would look worse" ... > > It was changed back in 2020: > bdc48fa11e46 ("checkpatch/coding-style: deprecate 80-column warning") > > seems to take a while to propagate out to all the subsystems :) Ah no, I was aware of that, but I guess we interpret this bit differently: +Statements longer than 80 columns should be broken into sensible chunks, +unless exceeding 80 columns significantly increases readability and does +not hide information. Here, I would've said something like: + if (request->request_lci && nla_put_flag(msg, NL80211_PMSR_FTM_REQ_ATTR_REQUEST_LCI)) + return -ENOBUFS; can indeed "be broken into sensible chunks, unless ..." Just like this one already did: + if (request->request_civicloc && + nla_put_flag(msg, NL80211_PMSR_FTM_REQ_ATTR_REQUEST_CIVICLOC)) + return -ENOBUFS; Personally I think the latter is easier to read because scanning the long line for the logical break at "&&" is harder for me, but YMMV. johannes