On Wed, 2008-10-29 at 15:27 +0000, Dave wrote: > > -static inline u8 *orinoco_get_ie(u8 *data, size_t len, > > - enum ieee80211_mfie eid) > > +static inline u8 *orinoco_get_ie(u8 *data, size_t len, u8 eid) > > Would it be better to change to enum ieee80211_eid here? Not sure. You could very well use it to find arbitrary IEs that don't have constants, or find dynamic ones based on a u8 variable. I don't really care, up to you, which would you prefer? > > @@ -839,7 +838,8 @@ static int orinoco_change_mtu(struct net > > if ( (new_mtu < ORINOCO_MIN_MTU) || (new_mtu > ORINOCO_MAX_MTU) ) > > return -EINVAL; > > > > - if ( (new_mtu + ENCAPS_OVERHEAD + IEEE80211_HLEN) > > > + /* MTU + encapsulation + header length */ > > + if ( (new_mtu + ENCAPS_OVERHEAD + 24) > > > I think that constant should be 30. I'd prefer it if we didn't use a > magic number here. How about sizeof(ieee80211_hdr)? I wanted to use sizeof, but then I checked and realised the driver doesn't support WDS mode, so it never needs a 4-addr header format, so 24 is the right header size. > > @@ -3289,7 +3289,7 @@ static int orinoco_init(struct net_devic > > > > /* No need to lock, the hw_unavailable flag is already set in > > * alloc_orinocodev() */ > > - priv->nicbuf_size = IEEE80211_FRAME_LEN + ETH_HLEN; > > + priv->nicbuf_size = IEEE80211_MAX_FRAME_LEN + ETH_HLEN; > > Note that this changes nicbuf_size from 2334 to 2352. I don't expect any > problems, and haven't noticed anything while running my version with > this change. Oh. I wasn't aware the constants differed. What's this used for? johannes
Attachment:
signature.asc
Description: This is a digitally signed message part