On 10/17/22 21:41, Kees Cook wrote:
static const iw_handler orinoco_handler[] = {
IW_HANDLER(SIOCSIWCOMMIT, orinoco_ioctl_commit),
- IW_HANDLER(SIOCGIWNAME, (iw_handler)cfg80211_wext_giwname),
+ IW_HANDLER(SIOCGIWNAME, cfg80211_wext_giwname),
This hunk should be in the orinoco patch, I think?
I just didn't want to have this huge patch touching multiple
different files. That's why I decided to split it up into three
separate patches.
But yeah; now it seems like a good idea to merge patches 1 to 3
into just a single patch.
[...]
+ [IW_IOCTL_IDX(SIOCGIWRETRY)] = cfg80211_wext_giwretry,
The common practice seems to be to use IW_HANDLER instead of open-coding
it like this.
IW_HANDLER(SIOCGIWRETRY, cfg80211_wext_giwretry),
Yeah; I forget this after reverting Sami's changes:
32fc4a9ad56f ("cfg80211: fix callback type mismatches in wext-compat")
I'll fix it up. :)
Thanks for the feedback!
--
Gustavo