On Mon, Sep 13, 2021 at 10:30:25AM +0200, Jerome Pouiller wrote: > From: Jérôme Pouiller <jerome.pouiller@xxxxxxxxxx> > > The firmware API 3.8 introduces new statistic counters. These changes > are backward compatible. > > Signed-off-by: Jérôme Pouiller <jerome.pouiller@xxxxxxxxxx> > --- > drivers/staging/wfx/debug.c | 3 +++ > drivers/staging/wfx/hif_api_mib.h | 5 ++++- > 2 files changed, 7 insertions(+), 1 deletion(-) > > diff --git a/drivers/staging/wfx/debug.c b/drivers/staging/wfx/debug.c > index eedada78c25f..e67ca0d818ba 100644 > --- a/drivers/staging/wfx/debug.c > +++ b/drivers/staging/wfx/debug.c > @@ -109,6 +109,9 @@ static int wfx_counters_show(struct seq_file *seq, void *v) > > PUT_COUNTER(rx_beacon); > PUT_COUNTER(miss_beacon); > + PUT_COUNTER(rx_dtim); > + PUT_COUNTER(rx_dtim_aid0_clr); > + PUT_COUNTER(rx_dtim_aid0_set); > > #undef PUT_COUNTER Not related to the patch but the PUT_COUNTER macro should be called something like PRINT_COUNTER. It's not a get/put API. regards, dan carpenter