Kalle Valo <kvalo@xxxxxxxxxxxxxx> wrote: > If CONFIG_ATH11K_DEBUGFS is disabled there are warnings debug.c: > > drivers/net/wireless/ath/ath11k/debug.c:36:20: warning: 'htt_bp_lmac_ring' defined but not used [-Wunused-variable] > 36 | static const char *htt_bp_lmac_ring[HTT_SW_LMAC_RING_IDX_MAX] = { > | ^~~~~~~~~~~~~~~~ > drivers/net/wireless/ath/ath11k/debug.c:15:20: warning: 'htt_bp_umac_ring' defined but not used [-Wunused-variable] > 15 | static const char *htt_bp_umac_ring[HTT_SW_UMAC_RING_IDX_MAX] = { > | ^~~~~~~~~~~~~~~~ > > Fix this by refactoring debugfs code to debugfs.c. This also reduces the number > of ifdefs in debug.c and makes it easier to maintain the code. > > No functional changes. Compile tested only. > > Reported-by: YueHaibing <yuehaibing@xxxxxxxxxx> > Signed-off-by: Kalle Valo <kvalo@xxxxxxxxxxxxxx> 4 patches applied to ath-next branch of ath.git, thanks. da3a9d3c1576 ath11k: refactor debugfs code into debugfs.c cb4e57db2ff0 ath11k: debugfs: use ath11k_debugfs_ prefix 56292162b9a2 ath11k: rename debug_htt_stats.[c|h] to debugfs_htt_stats.[c|h] 568f06036ee2 ath11k: debugfs: move some function declarations to correct header files -- https://patchwork.kernel.org/patch/11781017/ https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches