Hi, This updates command flow to adapt newer firmware version. Changes since v2: - check the return value from __mt76_mcu_send_msg. - rename dev->fw_ver to '2.0'. - simplify is_v1 expression. - revise commit messages. Ryder Lee (7): mt76: mt7615: simplify mcu_set_bmc flow mt76: mt7615: simplify mcu_set_sta flow mt76: mt7615: add a helper to encapsulate sta_rec operation mt76: mt7615: add starec operating flow for firmware v2 mt76: mt7615: use new tag sta_rec_wtbl mt76: mt7615: switch mt7615_mcu_set_tx_ba to v2 format mt76: mt7615: switch mt7615_mcu_set_rx_ba to v2 format .../net/wireless/mediatek/mt76/mt7615/main.c | 12 +- .../net/wireless/mediatek/mt76/mt7615/mcu.c | 577 +++++++++--------- .../net/wireless/mediatek/mt76/mt7615/mcu.h | 8 +- .../wireless/mediatek/mt76/mt7615/mt7615.h | 20 +- 4 files changed, 310 insertions(+), 307 deletions(-) -- 2.18.0