On Wed, Jul 30, 2008 at 06:44:49PM -0700, Pavel Roskin wrote: > On Wed, 2008-07-30 at 18:23 -0700, Luis R. Rodriguez wrote: > > On Wed, Jul 30, 2008 at 6:16 PM, Pavel Roskin <proski@xxxxxxx> wrote: > > > On Mon, 2008-07-28 at 22:47 -0700, lrodriguez@xxxxxxxxxxx wrote: > > >> From: Sujith Manoharan <smanoharan@xxxxxxxxxxx> > > >> > > >> diff --git a/drivers/net/wireless/ath9k/ath9k.h b/drivers/net/wireless/ath9k/ath9k.h > > >> index 6fa1eb6..c3294c0 100644 > > >> --- a/drivers/net/wireless/ath9k/ath9k.h > > >> +++ b/drivers/net/wireless/ath9k/ath9k.h > > >> @@ -622,17 +622,15 @@ struct hal_country_entry { > > >> > > >> #define SM(_v, _f) (((_v) << _f##_S) & _f) > > >> #define MS(_v, _f) (((_v) & _f) >> _f##_S) > > >> -#define OS_REG_RMW(_a, _r, _set, _clr) \ > > >> +#define REG_RMW(_a, _r, _set, _clr) \ > > >> REG_WRITE(_a, _r, (REG_READ(_a, _r) & ~(_clr)) | (_set)) > > > > > > I think these are pretty good candidates for inline functions. I'm not > > > sure removing "OS_" is a useful intermediate step. It's better to keep > > > such massive changes to the minimum to avoid potential conflicts with > > > other patches. > > > > This was done in response to Johannes comments. This can be moved to > > inline though. > > It would be really nice. Explicit return types tend to unmask some > issues in the calling code, if there are any. > > I don't care if you are going to change the macros/functions themselves > in many steps, but let's avoid the need to rename all callers again. Agreed. Luis -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html