It has been reported that some laptops, equipped with NXP NFC300, have different ID then mentioned in the driver. While at it, I found that the driver has a lot of duplication and redundant platform data. The rest of the series (11 out of 12 patches) is dedicated to clean the driver up. Sedat, would be nice if you can compile kernel with this patch series applied and test on your laptop. In v2: - added new ID patch - added new clean up patch - Cc'ed to linux-wireless@ as well, since linux-nfc@ bounces my mails - Cc'ed to the reported of the problem with T470 laptop Andy Shevchenko (12): NFC: nxp-nci: Add NXP1001 to the ACPI ID table NFC: nxp-nci: Get rid of platform data NFC: nxp-nci: Convert to use GPIO descriptor NFC: nxp-nci: Add GPIO ACPI mapping table NFC: nxp-nci: Get rid of code duplication in ->probe() NFC: nxp-nci: Get rid of useless label NFC: nxp-nci: Constify acpi_device_id NFC: nxp-nci: Drop of_match_ptr() use NFC: nxp-nci: Drop comma in terminator lines NFC: nxp-nci: Remove unused macro pr_fmt() NFC: nxp-nci: Remove 'default n' for tests NFC: nxp-nci: Convert to SPDX license tags MAINTAINERS | 1 - drivers/nfc/nxp-nci/Kconfig | 1 - drivers/nfc/nxp-nci/core.c | 15 +-- drivers/nfc/nxp-nci/firmware.c | 13 +-- drivers/nfc/nxp-nci/i2c.c | 147 ++++++-------------------- drivers/nfc/nxp-nci/nxp-nci.h | 1 - include/linux/platform_data/nxp-nci.h | 27 ----- 7 files changed, 37 insertions(+), 168 deletions(-) delete mode 100644 include/linux/platform_data/nxp-nci.h -- 2.20.1