"Gustavo A. R. Silva" <gustavo@xxxxxxxxxxxxxx> wrote: > Make use of the struct_size() helper instead of an open-coded version > in order to avoid any potential type mistakes, in particular in the > context in which this code is being used. > > So, replace code of the following form: > > sizeof(*ce_hdr) + CE_COUNT * sizeof(ce_hdr->entries[0]) > > with: > > struct_size(ce_hdr, entries, CE_COUNT) > > This code was detected with the help of Coccinelle. > > Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx> > Signed-off-by: Kalle Valo <kvalo@xxxxxxxxxxxxxx> Patch applied to ath-next branch of ath.git, thanks. 4f735cd73650 ath10k: coredump: use struct_size() helper -- https://patchwork.kernel.org/patch/10884377/ https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches