"Gustavo A. R. Silva" <gustavo@xxxxxxxxxxxxxx> wrote: > Make use of the struct_size() helper instead of an open-coded version > in order to avoid any potential type mistakes, in particular in the > context in which this code is being used. > > So, replace code of the following form: > > sizeof(struct usb_req_write_regs) + count * sizeof(struct reg_data) > > with: > > struct_size(req, reg_writes, count) > > This code was detected with the help of Coccinelle. > > Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx> Patch applied to wireless-drivers-next.git, thanks. 0c7beb2db9a5 zd1211rw: use struct_size() helper -- https://patchwork.kernel.org/patch/10884349/ https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches