"Gustavo A. R. Silva" <gustavo@xxxxxxxxxxxxxx> wrote: > Make use of the struct_size() helper instead of an open-coded version > in order to avoid any potential type mistakes, in particular in the > context in which this code is being used. > > So, replace code of the following form: > > sizeof(*pmkids) + max_pmkids * sizeof(pmkids->bssid_info[0]) > > with: > > struct_size(pmkids, bssid_info, num_pmkids) > > This code was detected with the help of Coccinelle. > > Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx> Patch applied to wireless-drivers-next.git, thanks. d442af2e1bcb rndis_wlan: use struct_size() helper -- https://patchwork.kernel.org/patch/10884341/ https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches