"Gustavo A. R. Silva" <gustavo@xxxxxxxxxxxxxx> wrote: > One of the more common cases of allocation size calculations is finding > the size of a structure that has a zero-sized array at the end, along > with memory for some number of elements for that array. For example: > > struct foo { > int stuff; > struct boo entry[]; > }; > > size = sizeof(struct foo) + count * sizeof(struct boo); > instance = kzalloc(size, GFP_KERNEL) > > Instead of leaving these open-coded and prone to type mistakes, we can > now use the new struct_size() helper: > > instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL) > > Notice that, in this case, variable reqsz is not necessary, > hence it is removed. > > This code was detected with the help of Coccinelle. > > Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx> Patch applied to wireless-drivers-next.git, thanks. 0cf83903aad0 brcmfmac: Use struct_size() in kzalloc() -- https://patchwork.kernel.org/patch/10884189/ https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches