"Gustavo A. R. Silva" <gustavo@xxxxxxxxxxxxxx> wrote: > One of the more common cases of allocation size calculations is finding > the size of a structure that has a zero-sized array at the end, along > with memory for some number of elements for that array. For example: > > struct foo { > int stuff; > struct boo entry[]; > }; > > size = sizeof(struct foo) + count * sizeof(struct boo); > instance = kzalloc(size, GFP_KERNEL) > > Instead of leaving these open-coded and prone to type mistakes, we can > now use the new struct_size() helper: > > size = struct_size(instance, entry, count); > > or > > instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL) > > Based on the above, replace qtnf_cmd_acl_data_size() with the > new struct_size() helper. > > This code was detected with the help of Coccinelle. > > Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx> > Reviewed-by: Sergey Matyukevich <sergey.matyukevich.os@xxxxxxxxxxxxx> Patch applied to wireless-drivers-next.git, thanks. 95336d4cb588 qtnfmac: replace qtnf_cmd_acl_data_size() with struct_size() -- https://patchwork.kernel.org/patch/10884311/ https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches