On Tue, Mar 12, 2019 at 05:25:50PM +0100, Lorenzo Bianconi wrote: > > buf = &q->entry[idx].ubuf; > > - buf->buf = skb->data; > > - buf->len = skb->len; > > + if (!dev->usb.sg_en) { > > + buf->urb->transfer_buffer = skb->data; > > I think you can move this in mt76u_tx_build_sg or remove the if condition in > mt76u_tx_build_sg() I'll rename mt76u_tx_build_sg() to mt76u_tx_setup_bufffers() then, which will more corresponding the what the function do. Stanislaw