Search Linux Wireless

Re: [PATCH] mt76: usb: reduce code indentation in mt76u_alloc_tx

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



> On Sat, 2019-03-02 at 14:50 +0100, Lorenzo Bianconi wrote:
> > Improve code readability reducing code indentation in
> > mt76u_alloc_tx
> 
> Trivial note below:
> 
> > diff --git a/drivers/net/wireless/mediatek/mt76/usb.c b/drivers/net/wireless/mediatek/mt76/usb.c
> []
> > @@ -787,6 +787,7 @@ static int mt76u_alloc_tx(struct mt76_dev *dev)
> >  {
> >  	struct mt76u_buf *buf;
> >  	struct mt76_queue *q;
> > +	size_t size;
> >  	int i, j;
> >  
> >  	for (i = 0; i < IEEE80211_NUM_ACS; i++) {
> > @@ -810,15 +811,15 @@ static int mt76u_alloc_tx(struct mt76_dev *dev)
> >  			if (!buf->urb)
> >  				return -ENOMEM;
> >  
> > -			if (dev->usb.sg_en) {
> > -				size_t size = MT_SG_MAX_SIZE *
> > -					      sizeof(struct scatterlist);
> > +			if (!dev->usb.sg_en)
> > +				continue;
> >  
> > -				buf->urb->sg = devm_kzalloc(dev->dev, size,
> > -							    GFP_KERNEL);
> > -				if (!buf->urb->sg)
> > -					return -ENOMEM;
> > -			}
> > +			size = MT_SG_MAX_SIZE * sizeof(struct scatterlist);
> > +
> > +			buf->urb->sg = devm_kzalloc(dev->dev, size,
> > +						    GFP_KERNEL);
> 
> Perhaps eliminate size and use devm_kcalloc instead like
> the allocation immediately above this.
> ---
>  drivers/net/wireless/mediatek/mt76/usb.c | 18 +++++++++---------
>  1 file changed, 9 insertions(+), 9 deletions(-)
> 
> diff --git a/drivers/net/wireless/mediatek/mt76/usb.c b/drivers/net/wireless/mediatek/mt76/usb.c
> index ae6ada370597..fc87ae223f8d 100644
> --- a/drivers/net/wireless/mediatek/mt76/usb.c
> +++ b/drivers/net/wireless/mediatek/mt76/usb.c
> @@ -806,15 +806,15 @@ static int mt76u_alloc_tx(struct mt76_dev *dev)
>  			if (!buf->urb)
>  				return -ENOMEM;
>  
> -			if (dev->usb.sg_en) {
> -				size_t size = MT_SG_MAX_SIZE *
> -					      sizeof(struct scatterlist);
> -
> -				buf->urb->sg = devm_kzalloc(dev->dev, size,
> -							    GFP_KERNEL);
> -				if (!buf->urb->sg)
> -					return -ENOMEM;
> -			}
> +			if (!dev->usb.sg_en)
> +				continue;
> +
> +			buf->urb->sg = devm_kcalloc(dev->dev,
> +						    MT_SG_MAX_SIZE,
> +						    sizeof(*buf->urb->sg),
> +						    GFP_KERNEL);
> +			if (!buf->urb->sg)
> +				return -ENOMEM;
>  		}
>  	}
>  	return 0;
> 

ack, I will post a v2, thx

Regards,
Lorenzo

> 

Attachment: signature.asc
Description: PGP signature


[Index of Archives]     [Linux Host AP]     [ATH6KL]     [Linux Wireless Personal Area Network]     [Linux Bluetooth]     [Wireless Regulations]     [Linux Netdev]     [Kernel Newbies]     [Linux Kernel]     [IDE]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]

  Powered by Linux