"Gustavo A. R. Silva" <gustavo@xxxxxxxxxxxxxx> wrote: > One of the more common cases of allocation size calculations is finding the > size of a structure that has a zero-sized array at the end, along with memory > for some number of elements for that array. For example: > > struct foo { > int stuff; > void *entry[]; > }; > > instance = kzalloc(sizeof(struct foo) + sizeof(void *) * count, GFP_KERNEL); > > Instead of leaving these open-coded and prone to type mistakes, we can now > use the new struct_size() helper: > > instance = kzalloc(struct_size(instance, entry, count), GFP_KERNEL); > > This code was detected with the help of Coccinelle. > > Signed-off-by: Gustavo A. R. Silva <gustavo@xxxxxxxxxxxxxx> > Reviewed-by: Sergey Matyukevich <sergey.matyukevich.os@xxxxxxxxxxxxx> Patch applied to wireless-drivers-next.git, thanks. db040dfa53e2 qtnfmac: use struct_size() in kzalloc() -- https://patchwork.kernel.org/patch/10752601/ https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches