On Tue, 2018-10-09 at 17:14 +0530, Ajay Singh wrote: > On 10/9/2018 4:06 PM, Johannes Berg wrote: > > On Tue, 2018-10-09 at 16:04 +0530, Ajay Singh wrote: > > > > > > > +typedef void (*wilc_remain_on_chan_expired)(void *, u32); > > > > > +typedef void (*wilc_remain_on_chan_ready)(void *); > > > > > > I think as per coding style the typedef for function pointer are allowed. > > > > True, I guess, but why do you need them? > > Actually these function pointer are used in multiple places i.e inside > the struct and also for passing as the argument for the function. So i > think its better to keep them as typedef to simplify and avoid any 'line > over 80 chars' checkpatch issue. But anyway if you suggest we can modify > to remove these typedefs . I guess that must be part of the internal bounce buffer mechanism? I guess leave them for now and see what falls out. > > > > > +struct hidden_network { > > > > > > Yes, its not related to hidden SSID. Suppose cfg80211 scan is called > with SSID information(active scan) then SSID info will be maintained in > this structure. so maybe rename this? johannes