On Thu, Sep 27, 2018 at 11:01:37AM +0200, Lorenzo Bianconi wrote: > Move mt76x2_wait_for_bbp utility routine in mt76x02_util.h > in order to be resued by mt76x0 driver > > Signed-off-by: Lorenzo Bianconi <lorenzo.bianconi@xxxxxxxxxx> > --- > +static inline bool mt76x02_wait_for_bbp(struct mt76_dev *dev) > +{ > + return __mt76_poll_msec(dev, MT_MAC_STATUS, > + MT_MAC_STATUS_TX | MT_MAC_STATUS_RX, > + 0, 100); > +} I think this should be renamed to mt76x02_wait_for_txrx_busy() or similar name, to avoid confusion and should be also used in mt76x0 to replace: if (!mt76_poll_msec(dev, MT_MAC_STATUS, MT_MAC_STATUS_TX | MT_MAC_STATUS_RX, 0, 1000)) Regards Stanislaw