Anilkumar Kolli <akolli@xxxxxxxxxxxxxx> writes: > This patch adds per station tx statistics support. > > Per station tx stats include > - pkts/bytes transmitted at all possible rates(mcs/nss/bw/gi). > - ACK fails count > - ampdu bytes/pkts transmitted at all possible rates(mcs/nss/bw/gi). > - BA fails count > > Tested on QCA9984/QCA4019/QCA988x > Firmware: 10.4-3.5.3-00057 > 10.2.4-1.0-00037 > > Signed-off-by: Anilkumar Kolli <akolli@xxxxxxxxxxxxxx> [...] > --- a/drivers/net/wireless/ath/ath10k/wmi.h > +++ b/drivers/net/wireless/ath/ath10k/wmi.h > @@ -4958,10 +4958,15 @@ enum wmi_rate_preamble { > #define ATH10K_HW_GI(flags) (((flags) >> 5) & 0x1) > #define ATH10K_HW_RATECODE(rate, nss, preamble) \ > (((preamble) << 6) | ((nss) << 4) | (rate)) > - > -#define VHT_MCS_NUM 10 > -#define VHT_BW_NUM 4 > -#define VHT_NSS_NUM 4 > +#define ATH10K_HW_AMPDU(flags) (flags & 0x1) > +#define ATH10K_HW_BA_FAIL(flags) (((flags) >> 1) & 0x3) > + > +#define NUM_VHT_MCS 10 > +#define NUM_BW 4 > +#define NUM_NSS 4 > +#define NUM_LEGACY 12 > +#define NUM_GI 2 > +#define NUM_HT_MCS 32 Why are you renaming these to use NUM_ prefix? That looks odd to me, usually the "NUM" is the last. If changing something, you should add ATH10K_ prefix to missing defines. -- Kalle Valo