Andres Rodriguez <andresx7@xxxxxxxxx> writes: >>> + fwctx->nvram_name, fwctx->dev, >>> + GFP_KERNEL, fwctx, >>> brcmf_fw_request_nvram_done); >>> /* pass NULL to nvram callback for bcm47xx fallback */ >>> @@ -547,7 +548,7 @@ int brcmf_fw_get_firmwares_pcie(struct device *dev, u16 flags, >>> fwctx->domain_nr = domain_nr; >>> fwctx->bus_nr = bus_nr; >>> - return request_firmware_nowait(THIS_MODULE, true, code, dev, >>> + return request_firmware_nowait2(THIS_MODULE, true, false, code, dev, >>> GFP_KERNEL, fwctx, >>> brcmf_fw_request_code_done); >>> } >> >> Also the number two in the function name is not really telling anything. >> I think that something like request_firmware_nowait_nowarn() would be >> better, even if it's so ugly. >> > > The 2 is meant to signify that this is an new version of the api with > different parameters. Ah, I missed that. I didn't have time to review your patches in detail, just looked at the wireless patches. > I don't think we need to codify into the name what the new parameters > mean (mostly because when a 2 version of an api is implemented, usage > of the original version tends to be discouraged). Yeah, makes sense now. -- Kalle Valo