> + /* Remove QOS if present */ > + hdr = (struct ieee80211_hdr *)skb->data; > + if (ieee80211_is_data_qos(hdr->frame_control)) { > + hdr->frame_control &= ~cpu_to_le16(IEEE80211_STYPE_QOS_DATA); > + ieee80211_skb_trim_iv_icv(skb, IEEE80211_QOS_CTL_LEN, 0); Maybe you should rename that if you're going to use it for something other than IV/ICV :) And wouldn't it actually be more efficient in this case to just calculate hdrlen once? johannes
Attachment:
signature.asc
Description: This is a digitally signed message part