> This patch handles the 11h measurement request information element. > This is minimal requested implementation - refuse measurement. I haven't really read 11h or the -2007 wrt. the added material, but this seems a bit odd to me: > +static void ieee80211_send_measurement_req(struct net_device *dev, > + struct ieee80211_msrment_ie *request_ie, > + const u8 *da, const u8 *bssid, > + u8 dialog_token) > + msr_report->u.action.u.measurement.element_id = WLAN_EID_MEASURE_REPORT; It's sending a report after all, not a request. Maybe it should just be named "send_measurement_action"? > + msr_report->u.action.u.measurement.msr_elem.token = request_ie->token; > + msr_report->u.action.u.measurement.msr_elem.mode |= MSR_REPORT_REFUSED; Also, it seems to me that should be part of the arguments or you won't be able to use this function for anything else but sending a 'refused' report? > +/* measurement report mode field - refuse to generate a report */ > +#define MSR_REPORT_REFUSED BIT(2) That seems completely misplaced in sta_info.h to me? johannes
Attachment:
signature.asc
Description: This is a digitally signed message part