On 4/6/2016 10:19 AM, Joe Perches wrote: > On Tue, 2016-04-05 at 14:24 +0300, Maya Erez wrote: >> Add __func__ to all wil log macros for easier debugging. > I think this is unnecessary and merely bloats code size. > For all the _dbg calls, dynamic debug can add function names if > desired. > > If really desired, I suggest changing the logging functions to use > "%ps and __builtin_return_address(0) > > -- > To unsubscribe from this list: send the line "unsubscribe linux-wireless" > in > the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info > at http://vger.kernel.org/majordomo-info.html I implemented it with __builtin_return_address(0) at first but found its format less readable (e.g. wil_start_xmit+0x58/0x7e8). I agree that using __builtin_return_address(0) simplifies the code and I'm OK with your suggestion to use it. -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html