> +static inline int ieee80211_fctl_tods(struct ieee80211_hdr *hdr) > +static inline int ieee80211_fctl_fromds(struct ieee80211_hdr *hdr) These seem fine though I don't see why you implement them with a > 0 rather than != 0 comparison? > +static inline int ieee80211_fctl_has_a4(struct ieee80211_hdr *hdr) That seems fine too. > +static inline int ieee80211_ftype(struct ieee80211_hdr *hdr, u16 ftype) That, I think, is misnamed, it should be ieee80211_is_ftype() > +static inline int ieee80211_stype(struct ieee80211_hdr *hdr, u16 stype) > +{ > + return (hdr->frame_control & cpu_to_le16(stype)) != 0; > +} And that even seems implemented wrongly? stype is a 4-bit field, this doesn't make much sense to me. > +static inline int ieee80211_ftype_mgmt(struct ieee80211_hdr *hdr) > +static inline int ieee80211_ftype_ctl(struct ieee80211_hdr *hdr) > +static inline int ieee80211_ftype_data(struct ieee80211_hdr *hdr) similarly, ieee80211_is_data() (remove the ftype, everybody hacking wireless should know that data/mgmt/ctl are frame types) johannes
Attachment:
signature.asc
Description: This is a digitally signed message part