On Monday 12 May 2008, David Miller wrote: > From: Johannes Berg <johannes@xxxxxxxxxxxxxxxx> > Date: Sun, 11 May 2008 00:18:52 +0200 > > > This patch converts mac80211 and all drivers to have transmit > > information and status in skb->cb rather than allocating extra > > memory for it and copying all the data around. To make it fit, > > a union is used where only data that is necessary for all steps > > is kept outside of the union. > > > > A number of fixes were done by Ivo, as well as the rt2x00 part > > of this patch. > > > > Signed-off-by: Ivo van Doorn <IvDoorn@xxxxxxxxx> > > Signed-off-by: Johannes Berg <johannes@xxxxxxxxxxxxxxxx> > > Please create an IEEE80211_SKB_CB() or similar macro to wrap > these casts around with, like all other SKB CB users do. Johannes, I have such a function in rt2x00queue.h: static inline struct ieee80211_tx_info* get_skb_tx_info(struct sk_buff *skb) { return (struct ieee80211_tx_info *)skb->cb; } You could rename it and move that one into mac80211.h Ivo -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html