The ath10k_skb_cb structure wasn't really space efficient. Some stuff is removed or replaced with more compact representation. This cleanup is necessary for future features. The size of ath10k_skb_cb: before after x86-32 26 12 x86-64 34 20 v3: * rebase v2: * fix a bug (patch 7/9 introduced) Michal Kazior (9): ath10k: merge is_protected with nohwcrypt ath10k: rename function to adhere to naming convention ath10k: remove txmode from skb_cb ath10k: remove is_offchan ath10k: remove freq from skb_cb ath10k: pack up flags in skb_cb ath10k: fix tx header parsing ath10k: replace vdev_id and tid in skb cb ath10k: store msdu_id instead of txbuf pointers drivers/net/wireless/ath/ath10k/core.h | 28 +++----- drivers/net/wireless/ath/ath10k/htt.h | 4 +- drivers/net/wireless/ath/ath10k/htt_tx.c | 116 +++++++++++++++++++----------- drivers/net/wireless/ath/ath10k/mac.c | 117 ++++++++++++++++--------------- drivers/net/wireless/ath/ath10k/txrx.c | 15 ++-- drivers/net/wireless/ath/ath10k/wmi.c | 22 ++++-- 6 files changed, 173 insertions(+), 129 deletions(-) -- 2.1.4 -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html