On 10/02/2015 09:45 AM, Arend van Spriel wrote:
On 10/01/2015 03:43 PM, Chaehyun Lim wrote:
This patch replaces int8_t with s8 that is a preferred type.
Signed-off-by: Chaehyun Lim <chaehyun.lim@xxxxxxxxx>
---
drivers/staging/wilc1000/wilc_wfi_cfgoperations.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
b/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
index d781003..56c97c9 100644
--- a/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
+++ b/drivers/staging/wilc1000/wilc_wfi_cfgoperations.c
@@ -263,9 +263,9 @@ static void clear_duringIP(unsigned long arg)
g_obtainingIP = false;
}
-int8_t is_network_in_shadow(tstrNetworkInfo *pstrNetworkInfo, void
*pUserVoid)
+s8 is_network_in_shadow(tstrNetworkInfo *pstrNetworkInfo, void
*pUserVoid)
It seems to make more sense to use bool type here.
The memcmp in this function uses magic number 6 comparing BSSIDs. Should
change that to ETH_ALEN in separate patch.
Regards,
Arend
{
- int8_t state = -1;
+ s8 state = -1;
You can actually get rid of the state variable. Just replace the
statement 'state = i;' by 'return true;' and replace 'return state;' by
'return false;'.
int i;
if (u32LastScannedNtwrksCountShadow == 0) {
@@ -288,7 +288,7 @@ int8_t is_network_in_shadow(tstrNetworkInfo
*pstrNetworkInfo, void *pUserVoid)
void add_network_to_shadow(tstrNetworkInfo *pstrNetworkInfo, void
*pUserVoid, void *pJoinParams)
{
- int8_t ap_found = is_network_in_shadow(pstrNetworkInfo, pUserVoid);
+ s8 ap_found = is_network_in_shadow(pstrNetworkInfo, pUserVoid);
And here as well.
Regards,
Arend
u32 ap_index = 0;
u8 rssi_index = 0;
--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at http://vger.kernel.org/majordomo-info.html