> CC [M] drivers/net/wireless/mwl8k.o > drivers/net/wireless/mwl8k.c: In function â??mwl8k_bss_info_changedâ??: > drivers/net/wireless/mwl8k.c:3290:2: warning: â??ap_mcs_ratesâ?? may be used uninitialized in this function [-Wmaybe-uninitialized] > memcpy(cmd->mcs_set, mcs_rates, 16); > ^ > drivers/net/wireless/mwl8k.c:4987:5: note: â??ap_mcs_ratesâ?? was declared here > u8 ap_mcs_rates[16]; > ^ > > The warning was bogus. But the conditionals were rather complicated, > with multiple redundant checks. This consolidates the checking and > makes it more readable IMHO. > > Signed-off-by: John W. Linville <linville@xxxxxxxxxxxxx> Thanks, applied to wireless-drivers-next.git. Kalle Valo -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html