On 07/15/2015 07:49 PM, Emmanuel Grumbach wrote: > On Tue, Jul 14, 2015 at 3:41 PM, Denys Vlasenko > <vda.linux@xxxxxxxxxxxxxx> wrote: >> On Tue, Jul 14, 2015 at 2:38 PM, Sergei Shtylyov >> <sergei.shtylyov@xxxxxxxxxxxxxxxxxx> wrote: >>>> +#define IWL_READ_WRITE(static_inline) \ >>>> +static_inline void iwl_write8(struct iwl_trans *trans, u32 ofs, u8 val) \ >>>> +{ \ >>>> + trace_iwlwifi_dev_iowrite8(trans->dev, ofs, val); \ >>>> + iwl_trans_write8(trans, ofs, val); \ >>>> +} \ >>> [...] >>>> >>>> +#if !defined(CONFIG_IWLWIFI_DEVICE_TRACING) >>>> +IWL_READ_WRITE(static inline) >>> >>> Not static_inline? >> >> Yes. Here we are putting two words, "static inline", in front of every >> function definition. >> -- > > I'll try to come up with a patch that is easier for me to read, but I > am really busy right now. Ping me in a week if you have heard from me > earlier. So how it is going with this patch? In hindsight, I would use a different name for the macro parameter here: #define IWL_READ_WRITE(static_inline) \ +static_inline void iwl_write8(...) "static_inline" proved to be confusing. Maybe perform s/static_inline/func_qualifier/ on the patch... -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html