On Thursday, August 06, 2015 10:48:48 AM Heikki Krogerus wrote: > On Wed, Aug 05, 2015 at 05:02:18PM +0300, Andy Shevchenko wrote: > > On Wed, 2015-08-05 at 16:39 +0300, Heikki Krogerus wrote: > > > Marcos for easier creation of build-in property entries. > > > > > > Signed-off-by: Heikki Krogerus <heikki.krogerus@xxxxxxxxxxxxxxx> > > > --- > > > include/linux/property.h | 35 +++++++++++++++++++++++++++++++++++ > > > 1 file changed, 35 insertions(+) > > > > > > diff --git a/include/linux/property.h b/include/linux/property.h > > > index 76ebde9..204d899 100644 > > > --- a/include/linux/property.h > > > +++ b/include/linux/property.h > > > @@ -152,6 +152,41 @@ struct property_entry { > > > } value; > > > }; > > > > > > +#define PROP_ENTRY_U8(_name_, _val_) { \ > > > > PROP_ prefix is too generic. > > Maybe DEVPROP_ ? At least for the latter no records in the current > > sources. > > I disagree with that. IMO this kind of macros should ideally resemble > the structure name they are used to fill (struct property_entry in > this case). And there are already definitions for DEV_PROP_* to > describe the types, so using something like DEVPROP_* here is just > confusing. > > If PROP_ENTRY_* is really not good enough, we can change them > PROPERTY_ENTRY_*. But is PROP_ENTRY_* really so bad? > > Rafael, what is your opinion? I would prefer PROPERTY_ENTRY_ to be honest. It's not like we need to save characters here. Thanks, Rafael -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html