The subject is wrong. You are not patch mac80211, but bcrmsmac. On Wed, Jul 8, 2015 at 10:32 PM, Christophe JAILLET <christophe.jaillet@xxxxxxxxxx> wrote: > Replace a kmalloc+strcpy by an equivalent kstrdup in order to improve > readability. > > Signed-off-by: Christophe JAILLET <christophe.jaillet@xxxxxxxxxx> > --- > drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c | 4 +--- > 1 file changed, 1 insertion(+), 3 deletions(-) > > diff --git a/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c b/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c > index 4813506..8a6c077 100644 > --- a/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c > +++ b/drivers/net/wireless/brcm80211/brcmsmac/mac80211_if.c > @@ -1476,9 +1476,7 @@ struct brcms_timer *brcms_init_timer(struct brcms_info *wl, > wl->timers = t; > > #ifdef DEBUG > - t->name = kmalloc(strlen(name) + 1, GFP_ATOMIC); > - if (t->name) > - strcpy(t->name, name); > + t->name = kstrdup(name, GFP_ATOMIC); > #endif > > return t; > -- > 2.1.4 > > -- > To unsubscribe from this list: send the line "unsubscribe linux-wireless" in > the body of a message to majordomo@xxxxxxxxxxxxxxx > More majordomo info at http://vger.kernel.org/majordomo-info.html -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html