On Tue, 2015-06-02 at 23:35 -0700, Joe Perches wrote: > > + IEEE80211_HW_HAS_RATE_CONTROL, > > + IEEE80211_HW_RX_INCLUDES_FCS, > > It may be nicer to use specified bit numbers here. > > It may make compatibility easier and maybe it should be > written down that new entries are only to be added at > the bottom of the enum and not inserted in the middle. There's no reason for that, since it's pure kernel internal API any renumbering of these bits is perfectly fine. > This is similar to the broadcom tg3 driver, but a little different. > > The mechanism in tg3 compared to ieee80211_hw is > tg3_flag ieee80211_hw_check > tg3_flag_set ieee80211_hw_set > tg3_flag_clear ? > > Would a ieee80211_hw_clear be useful? See my reply to Julian. > Would it be clearer without the _check? Well, I thought it would read as ieee80211_hw "check has_rate_control" with this in a sense, for example. > > static ssize_t hwflags_read(struct file *file, char __user *user_buf, > > size_t count, loff_t *ppos) > > { > [] > > + for (i = 0; i < NUM_IEEE80211_HW_FLAGS; i++) { > > + if (test_bit(i, local->hw.flags)) > > Maybe use the ieee80211_hw_check() function? Obviously that won't work. :) I could use the _ieee80211 one, but I'm considering just getting rid of that one and inlining the test_bit into the macro instead. johannes -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html