On Mon, 2015-03-30 at 17:07 +0200, Johannes Berg wrote: > On Mon, 2015-03-30 at 08:03 -0700, Joe Perches wrote: > > > > diff --git a/net/mac80211/tx.c b/net/mac80211/tx.c > > [] > > > +void ieee80211_check_fast_xmit(struct sta_info *sta, gfp_t gfp) > > > +{ > > > + struct ieee80211_fast_tx build = {}, *fast_tx, *old; > > > > This "{}" memset should probably be moved farther down > > because there are many return paths that are possible > > before the memset is necessary. > > True. However, this isn't actually the fast path I'm interested in; the > function ieee80211_xmit_fast() is the one that we execute per packet, > this one is invoked very infrequently. I prefer the more readable way > here. Perhaps using {} as an initializer amidst multiple declarations on the same line isn't particularly readable and the explicit memset is better. -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html