Hi, Here's a bunch of cleanups and fixes associated with tx/rx rate code. Feel free to squash some of the patches if you think it makes sense or let me know which ones you want me to squash. There are a few checkpatch warnings for going over 80 chars. I decided to leave them be to avoid code wrapping which would make the code less readable than it is now in my opinion. I have 2 more patches for .set_bitrate_mask() callback which depend on this patchset. Once you apply this patchset to your `pending` branch let me know, please, so I can push the rest with git indexes your git repo will recognize. Michal Kazior (9): ath10k: move rate definitions to file start ath10k: derive rate from bitrate ath10k: drop RATETAB_ENT macro ath10k: add hw rate definitions ath10k: use hw rate definitions for fixed rate ath10k: simplify fixed rate selection ath10k: rework legacy rx rate decoding ath10k: deduplicate bitrate to rate idx conversion ath10k: document ofdm/5ghz rate offset with a macro drivers/net/wireless/ath/ath10k/htt.h | 1 + drivers/net/wireless/ath/ath10k/htt_rx.c | 64 ++---------- drivers/net/wireless/ath/ath10k/hw.h | 21 ++++ drivers/net/wireless/ath/ath10k/mac.c | 161 ++++++++++++++++++------------ drivers/net/wireless/ath/ath10k/mac.h | 5 + drivers/net/wireless/ath/ath10k/rx_desc.h | 22 ++++ drivers/net/wireless/ath/ath10k/wmi.c | 62 +----------- 7 files changed, 163 insertions(+), 173 deletions(-) -- 2.1.4 -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html